All Collections
Advanced usage
Which is the minimum Android version supported?
Which is the minimum Android version supported?
Jordi Giménez avatar
Written by Jordi Giménez
Updated over a week ago

The minimum Bugfender SDK version supported at the moment is 0.8.

Bugfender works with Android SDK version 16 and better, which is present in Android 4.1 or better. Please note TLS 1.2 is also required, which is only present in some versions of Android 4.x. TLS 1.2 is present in Android 5.0 and better.

Upcoming: on Thursday, Feb 8th, 2024, our certification authority (Let's Encrypt) will start using ISRG Root X1 without cross-signing, so Android 7.0 and earlier will not accept the new certificates, unless they have been manually configured to trust ISRG Root X1.

If you have an application with a lower Android version you can still integrate Bugfender but disable it for Android versions lower than Android 4.1. You do this by mentioning Bugfender inside conditional code:

if (android.os.Build.VERSION.SDK_INT >= android.os.Build.VERSION_CODES.JELLY_BEAN) {
    // only for Jelly Bean and newer versions

Your application will have a minSdkVersion lower than 16, so you will get a compilation error if you try to do this. Add the xmlns:tools namespace and use tools:overrideLibrary to ignore the minSdkVersion reported by Bugfender, like this:

<?xml version="1.0" encoding="utf-8"?>
<manifest package="com.bugfender.sample"
    <uses-sdk tools:overrideLibrary=""/>
Did this answer your question?